[【共享资源】] 如果软件发送不了下载此补丁安装分享MicrosoftEasyFix51044电脑补丁,当易语言访问不了网页访...

[复制链接]
查看6413 | 回复0 | 2020-9-5 02:26:40 | 显示全部楼层 |阅读模式
网页_访问_对象()这个方法在个别电脑访问特定网站访问不了,必须用 网页_访问() 这个方式

当网页出现这样的代码:0658B1A7-6D2E-474F-BC2C-D69E5B9E9A68    就需要安装本软件补丁





1.是把操作系统升级到Win10
2.如果你不想动win7可以试试这个方法——进入这个网址,然后点download,下载一个文件“MicrosoftEasyFix51044.msi”
https://support.microsoft.com/en-ae/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi
之后运行,就可以解决这个问题了

原因解析:据说(英文看不太懂)是因为龙珠的服务器只支持TLS 1.1或者1.2,而win7默认是1.0
如果第二部做完后仍连接不上,可以百度搜索一下win7如何激活TLS1.2

WinHttpApi:
本模块将Winhttp的常用Api封装为了一个HTTP请求类,不再是之前开源的一个单独函数,另外增加了自动处理重定向(API内部虽然也能处理,但某些时候存在问题,所以另外实现此效果),并增加了设置忽略服务器证书错误选项、以及当服务器响应401或407状态码以后可以cha询服务器支持的认证方式,同时还支持了设置安全协yi选项(“SSL2.0、SSL3.0、TLS1.0、TLS1.1、TLS1.2”)。
需要注意的是,Windows8以及更低版本的系统中,默认只启用SSL3.0、TLS1.0; 而Windows8.1以及更高版本系统中默认支持SSL3.0、TLS1.0、TLS1.1、TLS1.2。
如果是Windows7sp1系统的话,可以通过打补丁的方式启用TLS1.1和TLS1.2,更低版本的系统就不行了。

Zlibwapi.dll:
本模块封装了调用zlib库进行“gzip”、“deflate”的解压和压缩方法,这是一个开源库,本源码压缩包内打包了zlibwapi.dll,以后如果有更新大家也可以自行到官网下载源码编译动态链接库。
需要注意的是,至少需要的版本为“1.2.0.0”及更高版本。

模块源码(含“Zlibwapi.dll”):
Windows7 sp1启用TLS1.1和TLS1.2的更新包:  (包含zc表工具“MicrosoftEasyFix51044.msi”,x64更新包和x86更新包),安装更新包后使用zc表工具写入zc表即可。




下载地址: kb31402453.zip (1.53 MB, 下载次数: 1533)
村长黑科技是专业提供项目资源的服务的村长黑科技平台,如合购网赚项目、引流推广软件、软件程序开发等项目就选村长黑科技平台,参与或发布项目定制各种软件就来村长黑科技平台
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则